OS X nicht mit der neuesten NumPY-Version

Ich versuche, NumPY zu aktualisieren, indem du die pip install -U numpy , die "Requirement bereits up-to-date: numpy in /Library/Python/2.7/site-packages" liefert. Dann überprüft die Version mit import numpy und numpy.version.version ergibt '1.6.2' (alte Version). Python importiert numpy über den Pfad '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/numpy'. Bitte helfen Sie mir hier.

  • Umkehrung 'one-hot' Kodierung in Pandas
  • Numpy: Überprüfen Sie, ob float array ganze Zahlen enthält
  • Holen Sie sich den Schlüssel, der dem Minimalwert innerhalb eines Wörterbuchs entspricht
  • Drucken Sie ein Integer-Array als Hexadezimalzahlen
  • Wie kann ich scipy spärliche Matrizen (LIL, CSR, COO, DOK) schneller lesen / durchqueren?
  • Typecasting von PyArrayObject-Daten in ein C-Array
  • 2 Solutions collect form web for “OS X nicht mit der neuesten NumPY-Version”

    Sie können die alte Version von numpy aus entfernen

    /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/numpy

    .
    Löschen Sie einfach das numpy Paket von dort und dann versuchen, Numpy von der Python-Shell zu importieren.

    Die neue NumPY-Version würde (über Pip) in den Systempfad installieren, wo sie von Python nicht erkannt wurde. Um dies zu lösen, lief ich pip install --user numpy==1.7.1 zu spezifizieren möchte ich NumPY Version 1.7.1 auf meinem Python (User) Pfad. 🙂

    Python ist die beste Programmiersprache der Welt.