Tag: pip

Sortierung von sys.path: first virtualenv, dann / usr

Warum enthält sys.path /usr/… vor Verzeichnisse von meinem virtualenv? Ich schaffe das virtualenv mit – –system-site-packages Der sys.path sieht derzeit so aus: /home/my-virtualenv/src/foo /usr/lib/python2.7/site-packages <— /usr paths should be below /usr/lib64/python2.7/site-packages /home/my-virtualenv/lib/python27.zip /home/my-virtualenv/lib64/python2.7 /home/my-virtualenv/lib64/python2.7/plat-linux2 /home/my-virtualenv/lib64/python2.7/lib-tk /home/my-virtualenv/lib64/python2.7/lib-old /home/my-virtualenv/lib64/python2.7/lib-dynload /usr/lib64/python2.7 /usr/lib/python2.7 /usr/lib64/python2.7/lib-tk /home/my-virtualenv/lib/python2.7/site-packages Ich will alle Wege außerhalb meines virtualenv ( /usr… ) unter den Pfaden des […]

Bereitstellung von Django / Python 3.4 zu Heroku

Ich versuche, meine erste Beispiel-App mit Django / Heroku mit dem Django / Heroku Getting Started Tutorial zu implementieren. Meine Werkzeuge: Python 3.4 und Windows 7 PowerShell. Meine Herausforderung: Der Einsatz auf Heroku scheitert und ich bin mir nicht sicher, warum. Bei meinem ersten "git push" habe ich gesehen, dass python-2.7.0 standardmäßig verwendet wurde. Ich […]

Fehler beim Versuch, Pipe auf openSUSE zu installieren

Ich versuche, pip auf meinem Produktionsserver zu implementieren, habe aber einen unlogischen Fehler, wo es versucht, ohne Erfolg einen Komponent zu installieren, der bereits installiert ist. ~> sudo zypper in python-pip Loading repository data… Reading installed packages… Resolving package dependencies… Problem: python-pip-1.0.2-3.1.2.noarch requires python = 2.7, but this requirement cannot be provided uninstallable providers: python-2.7.2-7.10.1.i586[Updates-for-openSUSE-12.1-12.1-1.4] […]

Python, NetCDF4 und HDF5

Ich weiß nicht, warum diese Pakete immer so ein Schmerz zu installieren sind. Ich habe NetCDF / HDF5 für eine lange Zeit jetzt und es war immer eine reine Horror-Trip, die sie zu installieren oder richtig laufen, egal ob es auf Linux oder OSX ist, egal ob C, C ++ oder jetzt Python. Die einfache […]

Verhindern, dass das Paket auf alten Python-Versionen installiert wird

Was können wir in eine setup.py Datei setzen, um zu verhindern, dass Pip vom Sammeln und Versuchen, ein Paket zu installieren, wenn Sie eine nicht unterstützte Python-Version verwenden? Zum Beispiel ist magicstack ein Projekt, das mit dem magicstack Klassifikator aufgeführt ist: Programming Language :: Python :: 3 :: Only Also erwarte ich das folgende Verhalten, […]

"SSL-Zertifikat überprüft fehlgeschlagen" mit Pip, um Pakete zu installieren

Ich versuche, das Scrapy Paket (ua) für Python mit Pip zu installieren. Ich habe versucht, die Installation mit python 3 und python 2 zu machen, ich habe die setuptools wie folgt installiert / aktualisiert: $ pip3 install –upgrade setuptools , ich habe versucht, die Option –trusted-host wie –trusted-host zu verwenden: $ pip3 install –trusted-host pypi.python.org […]

LXML 3.3 mit Python 3.3 auf Windows 7 32-bit

Ich habe große Probleme mit dieser Installation. Bitte geben Sie eine ausführliche, Schritt-für-Schritt-Anleitung an .

Fehler beim Installieren von scikits.audiolab bei Verwendung von python setup.py egg_info

Ich versuche, scikits.audiolab mit dem Pip-Tool zu installieren. Pip erscheint, um den Befehl python setup.py egg_info aus dem scikits.audiolab Quellverzeichnis auszuführen. Wenn es so ist, bekomme ich diese Fehlermeldung: Andrews-MacBook-Pro-2:scikits.audiolab-0.11.0 andrewhannigan$ pip install scikits.audiolab Collecting scikits.audiolab Using cached scikits.audiolab-0.11.0.tar.gz Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 20, […]

Pip-Installation von gmpy2

Als ich Pip benutzt habe, um gmpy2 zu installieren, bekam ich immer die Version 1.16, also gmpy statt gmpy2. $ pip search gmpy gmpy – GMP or MPIR interface to Python 2.4+ and 3.x INSTALLED: 1.16 (latest) Gibt es eine Möglichkeit, gmpy2 direkt per Pip zu installieren?

Proxy-Bewusstsein mit Pip

Ich habe versucht, eine Python-Entwicklungsumgebung an meinem Arbeitsplatz einzurichten, um einige grundlegende Anwendungen zu erstellen. Ich kann nicht scheinen, um Pip zu arbeiten , zum Beispiel Ich pip install numpy in pip install numpy und erhalten Sie die folgende Fehlermeldung: Retrying (Retry(total=3, connect=None, read=None, redirect=None)) after connection broken by 'ConnectTimeoutError(<pip ._vendor.requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x035884B0>, 'Connection […]

Python ist die beste Programmiersprache der Welt.