Tag: pip

Pip auf OS X: installiert 2.6 Python nicht erkannt Module mit Pip2.6 installiert

Mit Python 2.6.8 und 2.7.10 (plus anaconda installiert etc.) auf meinem Mac musste ich 2.6.6 32-Bit (lange Geschichte) installieren, also habe ich es von dmg installiert. Mit dem Glück, als ich dann python2.6 in eine Schale eingegeben python2.6 , die 2.6. 6 Dolmetscher begann (wenn auch nur in diesem Tab, nicht in anderen – vielleicht […]

Schwierigkeiten beim Herunterladen der letzten Version meines Pakets von Pip

Ich habe vor kurzem mit Pypi für einige Verpackungen von ein paar Tools, die nützlich sind in meinem Alltag, aber ich habe Schwierigkeiten tatsächlich sicherzustellen, dass ich die neueste Version von meinem Paket herunterladen können. Das Paket in Frage ist pyfuzz und ich habe gerade auf Version 0.1.1 , aber aus irgendeinem Grund, wenn ich […]

Formatfehler bei Verwendung von pip install -e von GitHub. Wert der Verwendung von #egg?

Die folgenden Werke: pip install git+git://github.com/pydata/pandas@master Aber das folgende nicht: pip install -e git+git://github.com/pydata/pandas@master Der Fehler ist: –editable=git+git://github.com/pydata/pandas@master is not the right format; it must have #egg=Package Warum? Auch habe ich gelesen, dass die -e die folgenden: –egg Install as self contained egg file, like easy_install does. Was ist der Wert davon? Wann wäre das […]

Wie kann ich die Datei easy_install.exe drucken, um die Ausgabe im aktuellen Befehlsfenster zu drucken?

Ich laufe Windows 7 64 bit und habe easy_install installiert. Wenn ich easy_install von der Eingabeaufforderung aus fahre, öffnet es ein weiteres Fenster für die Ausgabe und schließt schnell, bevor ich in der Lage bin zu untersuchen, was getan wurde. Ich bin mir dieser Frage bewusst , aber denke, dass es vorzeitig geschlossen worden sein […]

Kann nicht psycopg2 in virtualenv "Fehler: stdarg.h: Keine solche Datei oder Verzeichnis"

HINWEIS: Dieser gleiche Fehler tritt auch bei der Verwendung von easy_install auf, andere Installationsmöglichkeiten … Ich bin fast genau das gleiche Problem wie ich versuche zu installieren psycopg2 auf Mac OS 10.6.3; Es behauptet, dass es nicht "stdarg.h" finden kann, aber ich kann sehen, dass es dort ist; was soll ich machen? , Außer ich […]

Probleme bei der Installation von factory_boy mit Pip

Ich arbeite an einem Django-Projekt. Ich pip install factory_boy meine Umgebung auf einer anderen Maschine auf und wenn ich pip install factory_boy , bekomme ich folgendes Traceback: Https://gist.github.com/JSweetman/35f59536d6b87a0ce8c0 Weiß jemand, was passiert? Ich installierte factory_boy in einer anderen Umgebung auf der gleichen Maschine und es funktionierte so bin ich nicht sicher, was los ist.

Apache + mod_wsgi – Python lädt nicht installierte Module

Ich habe einen Apache Server mit mod_wsgi und laufe ein Python 2.7 Skript. Das Skript verwendet das Python-Pillow-Modul, das über Pip installiert ist. Das Skript läuft normalerweise mit python script.py funktioniert okay, aber beim Ausführen des Skripts von wsgi – Eine ImportError Ausnahme wird für PIL geworfen. Dies ist die Apache-Konfiguration von /etc/apache2/sites-enabled/000-default.conf : <VirtualHost […]

Wie benutzt man Pip mit mehreren Instanzen von Python

Ich habe vor kurzem installiert python3 nur zu erkennen, dass mysql-python sowie viele andere Module wurden nicht gut mit ihm noch nicht unterstützt. Also habe ich den Pfad in meiner bashrc-Datei geändert, um auf eine Installation von python 2.7 zu zeigen. Das Problem ist, dass, wenn ich python 3 installiert habe ich auch verteilt und […]

Wie gefrieren Sie Anforderungen, die nicht lokal befriedigt werden können?

Ich schreibe eine Python App, um auf Heroku einzusetzen. Nach dem Heroku-Guide muss ich die Paketanforderungen in einer Pip requirements.txt Datei auflisten. Der Leitfaden weist mich an, die Pakete lokal zu installieren und dann pip freeze > requirements.txt auszuführen, um die eingefrorene Anforderungsdatei zu schreiben. Eines der Pakete, die ich bei der Bereitstellung auf Heroku […]

Pip install networkit fehler

Ich benutze die pip install networkit Bereitstellung von der Networkit-Homepage, aber ich weiß nicht, was hier los ist, das Terminal zeigt das: Downloading/unpacking networkit Downloading networkit-3.4.1.tar.gz (582kB): 582kB downloaded Running setup.py (path:/private/var/folders/sy/lzckft690rn8xfm2f1svp8p00000gn/T/pip_build_runze/networkit/setup.py) egg_info for package networkit Traceback (most recent call last): File "<string>", line 17, in <module> File "/private/var/folders/sy/lzckft690rn8xfm2f1svp8p00000gn/T/pip_build_runze/networkit/setup.py", line 2, in <module> from setup_util […]

Python ist die beste Programmiersprache der Welt.