Tag: pip

Python – Pipeline pyublas: Kann das Ei nicht bauen

Ich habe Probleme bei der Installation von PyUblas auf Ubuntu 14.04, per Pip. Ich benutze Python 2.7.6. Hier geht das log: Traceback (most recent call last): File "setup.py", line 248, in <module> scripts = scripts, File "/usr/lib/python2.7/distutils/core.py", line 111, in setup _setup_distribution = dist = klass(attrs) File "/tmp/tmpJjyKIr/distribute-0.6.35/setuptools/dist.py", line 225, in __init__ _Distribution.__init__(self,attrs) File "/usr/lib/python2.7/distutils/dist.py", […]

Wie kann ich es schaffen, Pakete in python-dev auf Windows-Systemen genau so auf Linux zu installieren?

Eigentlich können wir einfach installieren python-dev auf Linux verwenden Sie einfach den folgenden Befehl: Sudo apt-get install python-dev Da python mit Linux integriert ist. Aber kein solches Glück an Fenstern. Für den Eingang "pip install python-dev" gibt es kein entsprechendes Paket auf pypi.python.org. Welche Pakete sollte ich installieren, um sie zu entsprechen, wenn sie von […]

Pip Fehler bei der Installation

Immer wenn ich versuche zu installieren Pip usin die get-pip.py Skript, es gibt mir nur Fehler. Ran cmd als Admin, neu installierte Python schon .. Ich benutze python 2.7.9 Exception: Traceback (most recent call last): File "c:\users\alex temporõr\appdata\local\temp\tmp13p7cp\pip.zip\pip\basecommand.py", line 232, in main status = self.run(options, args) File "c:\users\alex temporõr\appdata\local\temp\tmp13p7cp\pip.zip\pip\commands\install.py", line 339, in run requirement_set.prepare_files(finder) File […]

Wie kann ich verschiedene Python-Bibliotheken in Jython installieren?

Ich weiß, dass ich Jython mit Java installieren kann und dass ich Jython verwenden kann, wo ich Python verwende. Die Jython-Schale funktioniert gut. In Jython, wie kann ich Bibliotheken wie lxml , Scrappy und BeautifulSoup installieren, die ich normalerweise per pip oder easy_install installieren easy_install

Wie installiere ich psycopg2 für python2.6 wenn es auch 2.7 installiert ist?

Ich habe versucht, psycopg2 für python2.6 zu installieren, aber mein System hat auch 2.7 installiert. Ich tat >sudo -E pip install psycopg2 Downloading/unpacking psycopg2 Downloading psycopg2-2.5.3.tar.gz (690kB): 690kB downloaded Running setup.py (path:/private/var/folders/yw/qn50zv_151bfq2vxhc60l8s5vkymm3/T/pip_build_root/psycopg2/setup.py) egg_info for package psycopg2 Installing collected packages: psycopg2 Running setup.py install for psycopg2 building 'psycopg2._psycopg' extension cc -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes […]

Python pfeilinstallationsfehler 'kann die Basisindex-URL nicht abrufen'

Ziemlich neue Benutzer aber haben grundlegendes Verständnis von Kommandozeile / Python. Beim Versuch, Pip durch Windows 8 Powershell installieren Sie die folgende Fehlermeldung: Cannot fetch index base URL https://pypi.python.org/simple/ Could not find any downloads that satisfy the requirement pip Cleaning up… No distributions at all found for pip Storing debug log for failure in C:\Users\xxxx\pip\pip.log […]

Deinstallieren Sie alle Python-Pakete, die von mir und ihren Abhängigkeiten installiert wurden, ohne meinen Mac zu beschädigen

Es gibt eine Menge Fragen, aber der richtige Weg scheinen manuell alles zu deinstallieren, was man nicht braucht. Pip nicht die Abhängigkeiten eines Pakets bei der Deinstallation deinstallieren und die Pip-autoremove wird als defekt gemeldet. Hier ist mein Puffer einfrieren: altgraph==0.10.2 backports-abc==0.5 bdist-mpkg==0.5.0 bonjour-py==0.3 certifi==2016.9.26 dask==0.12.0 macholib==1.5.1 matplotlib==1.3.1 modulegraph==0.10.4 nose==1.3.7 numpy==1.8.0rc1 Pillow==3.4.2 py2app==0.7.3 pyobjc-core==2.5.1 pyobjc-framework-Accounts==2.5.1 […]

Wie kann man eine fehlerhafte Installation installieren, die auf python 3.4 funktioniert, aber nicht in 3.5?

Ich habe versucht, numpy in Ubuntu verwenden, aber es scheitert mit Fehler: Das Importieren des Multiarray-Numpy-Erweiterungsmoduls ist fehlgeschlagen. Wahrscheinlich versuchen Sie, einen fehlgeschlagenen Build von numpy zu importieren. Wenn du mit einem numpy git repo arbeitest, versuch git clean -xdf (entfernt alle Dateien nicht unter Versionskontrolle). Ansonsten neulich neu installieren. Der Fang ist, dass ich […]

Python Pip installieren Anfrage [Sicherheit] haben Fehler

Ich habe versucht zu installieren Anfrage [Sicherheit] Pack mit Pip, aber haben einige Fehler auftreten, jeder weiß, wie zu tun, Danke. Exception: Traceback (most recent call last): File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 220, in main status = self.run(options, args) File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 299, in run requirement_set.prepare_files(finder) File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 370, in prepare_files ignore_dependencies=self.ignore_dependencies)) File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 601, […]

"Kann bei der Installation von Pip-Paket in Python 3 nicht den Namen __version__" importieren

Ich habe ein neues Venv mit Python 3.3.2 erstellt. Beim Versuch, das Kampagnen-Monitor-Paket per Pip zu installieren, ergibt sich: Running setup.py egg_info for package createsend Traceback (most recent call last): File "<string>", line 16, in <module> File "/vagrant/3.3.2venv/build/createsend/setup.py", line 5, in <module> from createsend import __version__ File "./createsend/__init__.py", line 1, in <module> from createsend import […]

Python ist die beste Programmiersprache der Welt.