Tag: pip

Kann python-Module auf virtualenv nicht mit requirements.txt installieren

Ich versuche, python-Module aus einer requirements.txt Datei auf einem virtualenv zu installieren. Pip läuft und installiert sie. Aber ich kann nicht importieren die Module installiert, noch sie zeigen, wenn ich pip freeze laufen. So gehe ich Pip (test)elssar@elssar-laptop:~$ sudo pip install -r /path/to/requirements.txt Ich habe sogar versucht, diesen Befehl aus dem Verzeichnis mit requirements.txt auszuführen, […]

Installieren des Pakets in Python

Ich habe in meinem Laptop sowohl python 2.7 und python 3.5 installiert. Wenn ich ein Paket installiere und zB benutze: pip install thunder-python oder easy_install thunder In der Eingabeaufforderung werden die Pakete für python 3.5 installiert. Wie kann ich die Pakete installieren, um sie in python 2.7 zu benutzen? Ich verwende Windows 10.

PIP hg + und git + lädt immer Paket ein, anstatt zufriedene Anforderung zu ermitteln

Meine andere Frage hier wurde gerade gefragt, warum pip svn+ immer wieder komplette Pakete. Jetzt habe ich eine Handvoll mehr Pakete in meiner pip_requirements Datei, die immer heruntergeladen werden, anstatt zu erkennen, dass die pip_requirements erfüllt sind. Sie sind folgende Typen: git+git://github.com/yuchant/django-jinja2.git hg+https://bitbucket.org/yuchant/django-storages Mit svn+ meine Pakete werden als zufrieden gestellt, unabhängig davon, ob ich […]

Kann nicht älteren wxPython in virtualenv installieren (kann die Datei nicht entpacken / kann das Archivformat nicht ermitteln)

Innerhalb eines virtualenv gebaut Python 2.6.6, versuche ich zu pip install die 2.8.10.1 2.6 Unicode dmg hier gefunden: pip install -Iv http://sourceforge.net/projects/wxpython/files/wxPython/2.8.10.1/wxPython2.8-osx-unicode-2.8.10.1-universal-py2.6.dmg/download Zugegeben, die URL ist ein bisschen erraten. Ich bekomme (das Protokoll in zwei): MacBook-Pro-de-Pyderman:Pyderman$ pip install -Iv http://sourceforge.net/projects/wxpython/files/wxPython/2.8.10.1/wxPython2.8-osx-unicode-2.8.10.1-universal-py2.6.dmg/download -U –trusted-host sourceforge.net Collecting http://sourceforge.net/projects/wxpython/files/wxPython/2.8.10.1/wxPython2.8-osx-unicode-2.8.10.1-universal-py2.6.dmg/download Starting new HTTP connection (1): sourceforge.net "GET /projects/wxpython/files/wxPython/2.8.10.1/wxPython2.8-osx-unicode-2.8.10.1-universal-py2.6.dmg/download HTTP/1.1" 302 […]

Python – Pakete von eigenem Server herunterladen

Ich frage mich, wie kann ich den Befehl setup.py installieren, um Pakete (via Pip) von meinem Server herunterzuladen. Ich kann Pip meine Server-Adresse, aber alle Dependecies von Pip-Server heruntergeladen werden. Vielleicht Lösung ist pip.ini / pip.conf? Tomek

Wie wechsle ich standardmäßig von python 2.6 auf 2.7

Wie wechsle ich standardmäßig von python 2.6 auf 2.7 ls -l /usr/bin/python* lrwxrwxrwx 1 root root 9 Jan 27 12:36 /usr/bin/python -> python2.6 lrwxrwxrwx 1 root root 9 Jan 27 12:36 /usr/bin/python2 -> python2.6 -rwxr-xr-x 2 root root 3664 Sep 13 00:25 /usr/bin/python26 -rwxr-xr-x 2 root root 3664 Sep 13 00:25 /usr/bin/python2.6 -rwxr-xr-x 1 root […]

Laden Sie Textdatei in Python-Modul nach der Installation mit Pip / anderen Installateur

Mein Ziel ist es, ein Programm zu machen, das ich für potenzielle Arbeitgeber / etc. Leicht zugänglich gemacht habe. Um … meine Fähigkeiten zu zeigen … oder was auch immer. Ich bin kein Informatiker, und ich habe noch nie ein Python-Modul geschrieben, das für die Installation gedacht ist, also bin ich neu in diesem Aspekt. […]

Fehler bei der Installation von Pandas in Pip

Ich laufe Kali linux, und wann immer ich sudo pip installieren Pandas, bekomme ich diese Import-Fehler: nickshoe@kali:~$ sudo pip install pandas Downloading/unpacking pandas Downloading pandas-0.14.0.tar.gz (6.5MB): 6.5MB downloaded Running setup.py (path:/tmp/pip_build_root/pandas/setup.py) egg_info for package pandas warning: no files found matching 'README.rst' no previously-included directories found matching 'doc/build' warning: no previously-included files matching '*.so' found anywhere […]

Optionen für die Installation von scikit-lernen

Von http://scikit-learn.org/dev/install.html#building-scikit-learn-with-pip pip install –user –install-option="–prefix=" -U scikit-learn Die – User-Flag fragt Pip, um scikit-Learn im $ HOME / .local-Ordner zu installieren und benötigt daher keine Root-Berechtigung. Diese Flagge sollte Pip ignorieren jede alte Version von Scikit-Learn zuvor auf dem System installiert, während profitieren von System-Pakete für numpy und scipy. Diese Abhängigkeiten können lang und […]

Pip installieren BeautifulSoup passiert nichts

Ich versuche, BeautifulSoup4 zu installieren und Probleme mit Pip. Ich habe Pip installiert, aber wenn ich gehe, um Pip installieren zu lassen, muss man einfach was passieren. Nur eine neue Linie kommt auf CMD z.B C: \ Python27 \ Scripts> Pip installieren BeautifulSoup C: \ Python27 \ Scripts> Wer hat irgendwelche Ideen? Das ist Windows […]

Python ist die beste Programmiersprache der Welt.