Tag: pip

Einschließlich .gitignore im Setup? – Fehler: existiert nicht oder nicht eine reguläre Datei

Setup.py from setuptools import setup, find_packages from os import path from functools import partial if __name__ == '__main__': package_name = 'gen' templates_join = partial(path.join, path.dirname(__file__), package_name, 'templates') setup( name=package_name, test_suite=package_name + '.tests', packages=find_packages(), package_dir={package_name: package_name}, package_data={package_name: [templates_join('.gitignore')]} ) Baum . ├── gen │ ├── __init__.py │ ├── templates │ │ ├── __init__.py │ │ ├── […]

Installieren von SciPy mit Pip

Es ist möglich, NumPy mit Pip mit pip install numpy . Gibt es eine ähnliche Möglichkeit mit SciPy ? ( pip install scipy funktioniert nicht.) Aktualisieren Das Paket SciPy ist ab sofort mit pip !

Python: Pip kann nicht setup.py finden

Wie kann ich Pip zu finden, um setup.py zu finden? Meine setup.py Datei befindet sich ~/setuptools-3.5.1 . ich rannte dustin@dustin:~$ python setuptools-3.5.1/setup.py egg_info running egg_info writing requirements to setuptools.egg-info/requires.txt writing setuptools.egg-info/PKG-INFO writing top-level names to setuptools.egg-info/top_level.txt writing dependency_links to setuptools.egg-info/dependency_links.txt writing entry points to setuptools.egg-info/entry_points.txt reading manifest file 'setuptools.egg-info/SOURCES.txt' reading manifest template 'MANIFEST.in' writing manifest […]

Gcc-4.0 Fehler beim Aufbau _imaging Erweiterung für PIL

Wenn ich PIL (oder Kissen) installiere, wird das Modul _imaging C nicht installiert. Dies ist ein häufiger Fehler und haben die Play-by-Play-Lösung von ApPeL gesehen, die die meisten hilfreich gefunden haben. Leider, wenn ich sudo python setup.py install , bekomme ich die folgende sudo python setup.py install : running install running build running build_py running […]

Pip installieren hunspell: Kann nicht öffnen Include-Datei: 'hunspell.h': Keine solche Datei oder Verzeichnis

Ich versuche zu pip install hunspell auf meinem Windows 10 x64 Maschine, aber ich bekomme die folgende Fehler: C:\Users\a>pip install hunspell Collecting hunspell Using cached hunspell-0.3.3.tar.gz Installing collected packages: hunspell Running setup.py install for hunspell … error Complete output from command c:\users\a\appdata\local\programs\python\python35-32\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\a\\AppData\\Local\\Temp\\pip-build-lmrkbjce\\hunspell\\setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install –record C:\Users\a\AppData\Local\Temp\pip-6k6fow3d-record\install-record.txt […]

Fehler wenn pythonpip rrdtool auf windows 7 installieren

Ich laufe windows 7 64 bit, Python v2.7.10 und pip v9.0.1 Ich habe versucht, rrdtool zu installieren, aber ich bekomme einen Fehler PS C:\Windows\system32> pip install rrdtool Collecting rrdtool Using cached rrdtool-0.1.11.tar.gz Complete output from command python setup.py egg_info: test_rrdtool.c c:\users\person\appdata\local\temp\tmp_python_rrdtoolvwty3u\test_rrdtool.c(2) : fatal error C1083: Cannot open incl ude file: 'rrd.h': No such file or […]

Pip install -U steem error Windows Kits

Ich versuche immer noch, Steem über die "Pip-Installation -U Steem" -Kommandierung zu installieren. Ich habe bereits getan, was David in diesem Thread vorgeschlagen hat Pip Fehler: Microsoft Visual C ++ 14.0 ist erforderlich , was bedeutet, dass ich das Microsoft Visual Paket installiert habe, das er dort verknüpft hat und den Installationsbefehl erneut ausgeführt hat. […]

Installieren von pyglfw auf OS X

Ich möchte Glow für Python installieren, also habe ich geritten pip3 install glfw Aber wenn ich versuche zu importieren glfw in Code Ich bekomme Fehler wie diese Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages/glfw.py", line 149, in <module> raise ImportError("Failed to load GLFW3 shared library.") ImportError: Failed to load […]

Pip nicht installieren, um Website-Pakete Verzeichnis aus virtualenv, wenn ich eine requirements.txt verwenden

Ich bin relativ neu zu laufen Python mit virtualenv so könnte dies eine einfache Lösung sein, aber ich kann nicht für das Leben von mir herauszufinden, was los ist. Ich laufe Windows 7 Professional x64 mit Python 2.7.5 installiert Ich habe Pip und virtualenv installiert. Ich habe ein Django-Projekt, das ich versuche zu arbeiten, auf […]

Pip installiert das Paket zweimal

Leider kann ich es nicht reproduzieren, aber wir haben es mehrmals gesehen: Pip installiert ein Paket zweimal. Wenn du das erste deinstallierst, wird das zweite sichtbar und kann auch deinstalliert werden. Meine Frage: Wie kann ich mit Python überprüfen, ob ein Paket zweimal installiert ist? Hintergrund: Ich möchte einen Test schreiben, der das überprüft (devOp) […]

Python ist die beste Programmiersprache der Welt.