Tag: pip

Pip oder easy_install mit Python 3.x explodieren bei der Installation von etwas mit mingw

Ich hatte das vcvarsall.bat Problem, also folgte ich den Anweisungen hier Wie benutzt man MinGW's Gcc Compiler bei der Installation von Python Paket mit Pip? . Jetzt bei der Verwendung von pip install lxml mit Python 3.2.2 auf Windows 7 bekomme ich folgende Fehlermeldung: C:\MinGW\bin\gcc.exe -mno-cygwin -mdll -O -Wall -IC:\Python32\include -IC:\Pytho n32\PC -c src/lxml/lxml.etree.c -o […]

Python: PIP Installationspfad, was ist der richtige Ort für diese und andere Addons?

Ich habe vor kurzem ein paar Probleme mit meiner Python-Installation und als Ergebnis habe ich gerade neu installiert Python und ich versuche, alle meine Addons auch richtig zu bekommen. Ich werde auf virtualenv nachsehen, um zu sehen, ob ich dies verhindern kann. Wenn ich which python in terminal ich tippe /Library/Frameworks/Python.framework/Versions/2.7/bin/python Ich verstehe das, um […]

Virtualenv – Python 3 – Ubuntu 14.04 64 Bit

Ich versuche, virtualenv für Python 3 auf Ubuntu 64bit 14.04 zu installieren. Ich habe Pip für Python3 installiert mit: pip3 install virtualenv Und alles funktioniert gut Nun, obwohl ich versuche, virtualenv Befehl zu verwenden, um tatsächlich die Umgebung zu erstellen und den Fehler zu bekommen, dass es nicht installiert ist (ich schätze, weil ich es […]

Kann nicht python gevent auf mac osx 10.10 bauen

Synopsis: pip install gevent funktioniert nicht. Graben, ich heruntergeladen die gevent.tar.gz und lief den Build manuell: python setup.py build , bekam den gleichen Fehler: running build running build_py running build_ext building 'gevent.core' extension clang -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -U__llvm__ -DLIBEV_EMBED=1 -DEV_COMMON= -DEV_CLEANUP_ENABLE=0 -DEV_EMBED_ENABLE=0 -DEV_PERIODIC_ENABLE=0 -Ibuild/temp.macosx-10.10-x86_64-2.7/libev -Ilibev -I/Users/travisjohnson/.pyenv/versions/2.7.5/include/python2.7 -c gevent/gevent.core.c -o build/temp.macosx-10.10-x86_64-2.7/gevent/gevent.core.o In file […]

Programmatisch überprüfen, ob Python-Abhängigkeiten erfüllt sind

Ich möchte programmgesteuert pip ausführen und feststellen, ob die aktuelle virtualenv-Umgebung mit einer bestimmten requirements.txt Datei requirements.txt . Ich bin nicht über das pip oder irgendetwas geplaudert, aber ich dachte, da es die requirements.txt lesen kann.Txt -ähnliche Dateien, es wäre ein guter Anfang. Allerdings habe ich noch nicht einmal einen Weg gefunden, um effektiv pip […]

Sudo erforderlich für easy_install pip in OS X Lion?

Ich komme von Snow Leopard bei der Arbeit zu einer Lion Installation zu Hause. Ich erinnere mich nicht mehr: sudo easy_install pip Ist das für Lion erforderlich? Ich habe Fehler, bis ich das getan habe, und Pip hat hier gelogen: [ some@computer ] ~ $ which pip /usr/local/bin//pip Bedeutet das, dass ich zu sudo pip […]

Installiere das Python-Modul mit einer Zip-Datei

Ich habe eine Zip-Datei von hier heruntergeladen , aber ich weiß nicht, wie man es installiert und dann benutze es in meiner Python 2.7 sie sagten, dass es sowohl python 2 und 3 unterstützt Mit Befehl: "Pip installieren Hazm" nach Bündel von Zeilen bekommt es zu diesen Fehlern: creating build\temp.win-amd64-2.7\Release\libwapiti\src C:\Users\Mohammad\AppData\Local\Programs\Common\Microsoft\Visual C++ for Pyt hon\9.0\VC\Bin\amd64\cl.exe […]

Django Installation: kann nicht Pip verwenden, um django auf Linux zu installieren (Ubuntu)

Ich habe versucht, django auf Ubuntu mit Pip installieren. Aber leider habe ich so Fehler bekommen Kann jemand das erklären und mir irgendwelche Möglichkeiten geben, dies zu beheben? error: could not create '/usr/local/lib/python2.7/dist-packages/django': Permission denied —————————————- Command /usr/bin/python -c "import setuptools;__file__='/home/franklingu/build/django /setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install –single-version-externally-managed –record /tmp/pip-W5MhGe-record/install-record.txt failed with error code 1 Storing […]

Wie installiere ich dieses Rad?

Ich habe es geschafft, Pip zu installieren, aber wenn ich Pip verwenden, um das heruntergeladene Rad zu installieren, druckt es: C:\Python34\Scripts\pip install pygame-1.9.2a0-cp34-none-win_amd64.whl Requirement 'pygame-1.9.2a0-cp34-none-win_amd64.whl' looks like a filename, but the file does not exist pygame-1.9.2a0-cp34-none-win_amd64.whl is not a supported wheel on this platform Die Datei befindet sich im selben Ordner (Scripts) mit Pip. Ich […]

Optionale Abhängigkeiten in einer Pip-Anforderungsdatei

Wie kann ich optionale Abhängigkeiten in einer Pip-Anforderungsdatei angeben? Nach der Pip-Dokumentation ist dies möglich, aber die Dokumentation erklärt nicht, wie es geht und ich kann keine Beispiele im Web finden.

Python ist die beste Programmiersprache der Welt.