Tag: osx

Vim nicht mit Python auf OS X kompilieren

Ich habe versucht, vim 7.3 mit python 2.7 Unterstützung auf Mac OS X 10.6 zu kompilieren. Vim selbst kompiliert gut, aber die eingebettete Python nicht so sehr. Die Schritte, die ich gemacht habe: hg clone https:/vim.googlecode.com/hg/ vim cd vim/src ./configure –without-x –disable-gui –disable-darwin \ –enable-pythoninterp –with-features=huge make make install Das gibt mir ein funktionierendes vim […]

Python mit Homebrew auf OS X verwenden

Ich habe Mac-Python für eine Weile benutzt, und ich beschloss, mich matplotlib zu unterrichten, weil ich die Erfahrung mit einigen gängigen Modulen haben möchte. Ich höre von jedem, dass, sobald Sie in Nicht-Standard-Module zu bekommen, ist es am besten zu verwenden Python warf Homebrew, so haben Sie Zugang zu pip und nicht easy_install . Nach […]

Wie installiere ich lxml auf OS X Leopard ohne MacPorts oder Fink?

Ich habe das versucht und in der Vergangenheit Probleme gemacht. Hat jemand ein Rezept für die Installation von lxml auf OS X ohne MacPorts oder Fink, die definitiv funktioniert? Vorzugsweise mit vollständigen 1-2-3 Schritten zum Herunterladen und Erstellen jeder der Abhängigkeiten.

Mac OSX – AttributeError: 'FigureCanvasMac' Objekt hat kein Attribut 'restore_region'

Gehen durch Matplotlibs Animation Beispiel auf meinem Mac OSX Maschine – http://matplotlib.org/examples/animation/simple_anim.html – Ich erhalte diese Störung: – File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/matplotlib/animation.py", line 248, in _blit_clear a.figure.canvas.restore_region(bg_cache[a]) AttributeError: 'FigureCanvasMac' object has no attribute 'restore_region' Hat jemand, der dies angetroffen hat, wissen, wie man dieses Problem lösen kann? Sieht aus wie es ist bekannt (und ungelöst zu diesem […]

'Bibliothek nicht geladen: @ rpath / libcudart.7.5.dylib' TensorFlow Fehler auf Mac

Ich benutze OS X El Capitan (10.11.4). Ich habe gerade TensorFlow heruntergeladen. Alles ging ziemlich reibungslos, obwohl ich ein paar Warnmeldungen bekam wie: The directory '/Users/myusername/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip […]

Warum funktioniert Python easy_install nicht auf meinem Mac?

Ich habe einen Mac mit Python 2.6. Wenn ich versuche, easy_install zu benutzen, easy_install ich diese Nachricht: /usr/bin/easy_install-2.6:7: UserWarning: Module pkg_resources was already imported from /System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkg_resources.pyc, but /Library/Python/2.6/site-packages is being added to sys.path from pkg_resources import load_entry_point /usr/bin/easy_install-2.6:7: UserWarning: Module site was already imported from /System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site.pyc, but /Library/Python/2.6/site-packages is being added to sys.path from pkg_resources […]

Pygame für Mac OS X installieren 10.6.8

Verwenden von Python 2.7.2. Wenn ich versuche, pygame zu importieren bekomme ich diese Fehlermeldung: Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pygame/__init__.py", line 95, in <module> from pygame.base import * ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pygame/base.so, 2): no suitable image found. Did find: /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pygame/base.so: no matching architecture in universal wrapper Ich bin nicht ganz […]

Python: MySQLdb und "Bibliothek nicht geladen: libmysqlclient.16.dylib"

Die Einrichtung… Ich versuche, einen sauberen Mac OS X 10.6 installieren, um Python / Django zu entwickeln und ich habe mich nicht daran erinnert, dass dies bei 10.5 läuft. Nach der Installation von MySQL aus dem Installer auf mysql-5.5.8-osx10.6-x86_64.dmg Ich lief $ sudo pip install MySQL-python Und es schien glatt zu gehen (Ausgabe unten) Downloading/unpacking […]

Mehrere Versionen von Python auf OS X Leopard

Ich habe derzeit mehrere Versionen von Python auf meinem Mac installiert, die, die mit ihm kam, eine Version, die ich vor kurzem von python.org heruntergeladen habe, eine ältere Version, die verwendet wurde, um Zope lokal auszuführen und eine andere Version, die Appengine verwendet. Es ist eine Art Chaos. Irgendwelche Empfehlungen der Verwendung einer Version von […]

Warum funktioniert apt-get-Funktion nicht im Terminal auf mac osx 10.9?

Ich habe das beobachtet und wie du den ersten Befehl sehen kannst, ist mir zu sagen: sudo apt-get install python-setuptools Wenn ich das mache, gibt es: sudo: apt-get: command not found Ich habe keine Ahnung, warum dies der Fall ist. Wie kann ich das lösen? Ich folge dem Tutorial richtig?

Python ist die beste Programmiersprache der Welt.