Tag: osx

Kann nicht Pip installieren, was C compilation auf OSX 10.10 mit homebrew python erfordert

Wenn ich versuche, pip install , die C-Kompilation beinhalten ( Pillow , speziell) bekomme ich einen seltsamen Fehler: clang: error: no such file or directory: 'Python.framework/Versions/2.7/Python' error: command 'clang' failed with exit status 1 —————————————- Cleaning up… Command /usr/local/opt/python/bin/python2.7 -c "import setuptools, tokenize;__file__='/private/var/folders/xt/f2d8vp4j65j2rt71pns6trjw0000gn/T/pip_build_jakob/Pillow/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install –record /var/folders/xt/f2d8vp4j65j2rt71pns6trjw0000gn/T/pip-LnL0hW-record/install-record.txt –single-version-externally-managed –compile failed with […]

Warum gibt es Unterschiede in Python time.time () und time.clock () unter Mac OS X?

Ich bin mit Mac OS X 10.8 und bekomme seltsame Verhalten für time.clock (), die einige Online-Quellen sagen, ich sollte lieber über time.time () für Timing mein Code. Beispielsweise: import time t0clock = time.clock() t0time = time.time() time.sleep(5) t1clock = time.clock() t1time = time.time() print t1clock – t0clock print t1time – t0time 0.00330099999999 <– from […]

Wie gehe ich "dot" als Befehl von Python?

Ich benutze Python auf Mac OSX Leopard. Ich versuche, das Programm 'dot' (Teil von Graphviz) von Python laufen zu lassen: # -*- coding: utf-8 -*- import os print os.environ['PATH'] print os.system("ls >> a.txt") print os.system("dot -o9.png -Tpng ./6.dot") Der Befehl "ls" gibt es nur um sicherzustellen, dass python im richtigen Verzeichnis ist. Es ist. Das […]

UnicodeDecodeError: 'ascii' Codec kann das Byte in 0xc3 nicht in Position 304 decodieren: Ordinal nicht im Bereich (128)

Ich habe gerade den PC bei der Arbeit (mit Python 2.7) und hatte ein Skript, dass ich gerade fertig war (wiedergegeben unten). Es lief gut bei der Arbeit, ich wollte nur ein oder zwei Dinge hinzufügen. Aber ich bin nach Hause gekommen und verwende meine Mac-Version von Python (3.2.2) und bekomme folgende Fehlermeldung: Traceback (most […]

OS X cmake kann PythonLibs nicht finden 3.4

Python und python3 sind in OS X Yosemite über Homebrew installiert, aber cmake findet keine PythonLibs 3, nur 2: CMakeLists.txt: set(Python_ADDITIONAL_VERSIONS 3.4) FIND_PACKAGE(PythonInterp REQUIRED) FIND_PACKAGE(PythonLibs 3.4 REQUIRED) bekommen: — Found PythonInterp: /usr/local/bin/python3.4 (found suitable version "3.4.3", minimum required is "3.4") — Found PythonLibs: /usr/lib/libpython3.4.dylib (found version "2.7.6" CMakeLists.txt: set(Python_ADDITIONAL_VERSIONS 3.4) FIND_PACKAGE(PythonInterp 3.4 REQUIRED) FIND_PACKAGE(PythonLibs 3.4 […]

AttributeError: 'module' Objekt hat kein Attribut 'PROTOCOL_TLSv1_2' mit Python 2.7.11

Ich habe Probleme bekommen tls v1.2 Unterstützung für meine Python-Installation auf meinem Mac. Dies ist meine openssl Version: openssl version OpenSSL 1.0.2h 3 May 2016 Und hier ist meine Python-Version: python –version Python 2.7.11 So tippe ich: >>> import ssl >>> ssl.PROTOCOL_TLSv1_2 Traceback (most recent call last): File "<stdin>", line 1, in <module> AttributeError: 'module' […]

"SSL-Zertifikat überprüft fehlgeschlagen" mit Pip, um Pakete zu installieren

Ich versuche, das Scrapy Paket (ua) für Python mit Pip zu installieren. Ich habe versucht, die Installation mit python 3 und python 2 zu machen, ich habe die setuptools wie folgt installiert / aktualisiert: $ pip3 install –upgrade setuptools , ich habe versucht, die Option –trusted-host wie –trusted-host zu verwenden: $ pip3 install –trusted-host pypi.python.org […]

ImportError: Kein Modul namens seriell

Ich habe ein Skript geschrieben in Python 3 mit 3.3.5 installiert, und ich bekomme diese Fehler aus dem Terminal, wenn ich versuche, es zu laufen. Ich benutze einen Mac, OSX 10.7.5 Ich habe bereits pyserial (mit Pip) für python 3 installiert. Um dies zu tun, habe ich zuerst Pip mit: $ curl -O http://python-distribute.org/distribute_setup.py $ […]

Linker Probleme mit MacPorts Installation von Graph-Tool

Ich habe das Grafik-Tool über Mac-Ports installiert. Vor ein paar Tagen lief ich $ sudo port selfupdate $ sudo port upgrade outdated Graph-Tool wurde neu kompiliert (das dauerte etwa 30 Stunden (!)) Nun, wenn ich grafisches Werkzeug in Python einschließen möchte, bekomme ich folgende Fehlermeldung: Python 2.7.6 (default, Nov 22 2013, 13:39:24) [GCC 4.2.1 Compatible […]

Spark (pyspark) mit Schwierigkeiten beim Aufruf von Statistikmethoden am Arbeiterknoten

Ich schlage einen Bibliotheksfehler beim Ausführen von Pyspark (von einem ipython-notebook), ich möchte die Statistics.chiSqTest(obs) von pyspark.mllib.stat in einer .mapValues Operation auf meinem RDD verwenden, die (Schlüssel, Liste (int) ) Paare. Auf dem Masterknoten, wenn ich die RDD als Karte sammle und über die Werte iteriere, so habe ich keine Probleme keys_to_bucketed = vectors.collectAsMap() keys_to_chi […]

Python ist die beste Programmiersprache der Welt.